Auteur Topic: Probleem met keyboards 6040  (gelezen 3397 keer)

Luc Van Landeghem

  • Gast
Probleem met keyboards 6040
« Gepost op: 08 juni 2012, 19:35:54 pm »
Ik heb 2 6040 keyboards aangesloten op een control unit 6021. De keyboards gebruik ik om lampen op verschillende stukken van mijn baan aan en uit te schakelen (via enkele M?rklin K84's). Sinds kort werkt mijn systeem niet meer. Zodra ik een keyboard aansluit aan de control unit (hetzelfde fenomeen doet zich met beide keyboards voor) gaan de LED's van de control unit uit en de meeste lampen van de 6040 branden ; schakelen lukt niet meer. Ik dacht eerst dat het aan de control unit lag maar met een nieuwe heb ik precies hetzelfde probleem.
Kan iemand me een suggestie aan de hand doen wat het probleem kan zijn en hoe ik het kan oplossen ?

Offline Gerolf

  • Administrator
  • Forumlid
  • Berichten: 20.947
    • Marche-en-Bières
  • Voornaam: Gerolf
Probleem met keyboards 6040
« Reactie #1 Gepost op: 12 juni 2012, 15:45:31 pm »
Even verplaatsen naar een meer geschikte rubriek, en dan krijgt Luc misschien w?l een antwoord ... [;)]
Groeten uit "Marche-en-Bières"   ** Modelspoor is plezant **   TPIII-H0-DC-Zelfbouw

Luc Van Landeghem

  • Gast
Probleem met keyboards 6040
« Reactie #2 Gepost op: 14 juni 2012, 17:58:19 pm »

 Op een ander (Nederlands) forum kreeg ik dit als antwoord. Kan dat kloppen ?


Hoe oud zijn de 6040? De eerste batches van de 6040 (1984 - ~1990) zijn uitgerust met een normale backup batterij. Deze wordt niet opgeladen als het systeem uit staat. De latere versies hebben oplaadbare batterij.
Onze 6040 vertoonden in 95 dezelfde problemen.

Ze zijn opgestuurd naar Borne, Keuterman voor 'reparatie'. Die heeft de oude batterijen vervangen door nieuwe oplaadbare. Dat zul jij ook moeten doen, of je moet zelf gaan slopen.

Dat ze hetzelfde euvel hebben, kan of toeval zijn, of er is iets serieus mis gegaan op de I2C bus, en is er iets opgeblazen in de 6040 bv de zener diode, en dan dedecteerd de proccessor niet meer dat ie aan de slag moet. En beide kunnen tegelijk zijn opgeblazen, omdat de bus hard is doorgevoerd. En als je dus niet zelf gaat solderen, is de oplossing hetzelfde: stuur het naar Keuterman via je Marklin winkel.

Offline Jurgen

  • Forumlid
  • Berichten: 6.762
    • Fietssporen
  • Voornaam: Jurgen
Probleem met keyboards 6040
« Reactie #3 Gepost op: 14 juni 2012, 18:10:28 pm »
Veel antwoord krijg je blijkbaar niet, jammer eigenlijk.

Ik heb er geen idee van wat het probleem zou kunnen zijn, maar je kan niets mis doen door ze even mee te nemen naar je handelaar.
Mvg, Jurgen
De trein, da's altijd een beetje wachten.
Fietssporen, fietsen over oude sporen.

Offline PeterC

  • Forumlid
  • Berichten: 3.347
    • JAL pagina
  • Voornaam: Peter
Probleem met keyboards 6040
« Reactie #4 Gepost op: 14 juni 2012, 18:35:13 pm »
Luc,
Ik wil je wel helpen, maar je gaat je moeten verplaatsen: ik heb een 6040 gekoppeld aan een IB.  Kom langs met je 6040's en je 6021.  Door de onderdelen te wisselen kunnen we uitsluiten wat defect is (en misschien uitvissen hoe en waarom...).

Groetjes, Peter


Offline PeterC

  • Forumlid
  • Berichten: 3.347
    • JAL pagina
  • Voornaam: Peter
Probleem met keyboards 6040
« Reactie #5 Gepost op: 15 juni 2012, 21:25:45 pm »
Om Luc te kunnen helpen, heb ik wat opzoekingen verricht.  Weinig te vinden en als er wat te vinden is, gaat het over de batterij.

Eerst en vooral het schema van zo'n 6040 (te groot om hier te tonen, daarom de link):

http://www.pallund.dk/marklin/pictures/6040.gif

Waarop duidelijk een 3V lithium batterij te zien is.

Om zeker te zijn, mijn eigen 6040 opgeofferd (zo'n Marklin toestel openen is onherroepelijk** - geen garantie meer) en eens binnenin gekeken: een totaal ander concept dan wat er op vorig schema staat...  Geen spoor van een batterij...








Volgens mij de enige oplossing is om Luc's 6040's te 'openen' en binnenin te zien.  Lithiumbatterij?  Gewoon vervangen...


**Om die Marklin toestellen te 'openen' heb ik een heel eenvoudig (maar onherroepelijk) middel: langs de zijkanten zitten vier pennetjes.  Die pennetjes zijn er niet uit te halen (toch niet met de middelen/kennis die ik heb).  Ik boor een 1mm gaatje in het center van die pennetjes (ongeveer 1mm diep).  Draai er een heel fijn schroefje in en trek er dan de pinnetjes uit.  Schroefje uit de pinnetjes halen en ze kunnen opnieuw gebruikt worden om de zaak te sluiten.  Die boorgaatjes kan je evenwel niet meer 'uitwissen'...
Groetjes, Peter