Modelspoormagazine forum

Modelspoor, praktijk => KISS en andere simpele elektronica => Topic gestart door: raf op 13 augustus 2019, 13:12:27 pm

Titel: opto couplers
Bericht door: raf op 13 augustus 2019, 13:12:27 pm
hallo

sommige hebben het misschien gevolgd en andere dan weer niet
maar dat doet niets af aan het probleem
het eerste probleem hoe groot moet de weerstand zijn voor zo een opto
de spanning is 5 volt
en dan vind je veel verschillende waarden
240 Ohm;150 Ohm;220 Ohm;100 Ohm;1K ;
dus eigenlijk tussen 100 Ohm en 1 K zit je normaal op 5 volt goed

maar als je der 4 diode's voor zet en deze als detectie gebruikt dan krijg je een heel ander verhaal
dan zit je met waarden van 0 Ohm tot  1K
welke waarde moet men hier kiezen?? ik ben voor 39 Ohm gegaan na overleg met gerolf

bezetmelding door 4 dioden 1n4007 een pc817 opto een led en voorschakel weerstand van 1 K
met een roco muis is er geen probleem de bezet melding werkt perfect
met een ecos station pinkt de led
blijkt dat het probleem ligt bij de rail com
de ecos zorgt dat er om de zoveel tijd een dode tijd in de data zit
zodat de decoders in de loco van deze tijd gebruik kunnen maken om data terug te zenden
deze dode tijd doet de led pinken met een 1 Hz frequentie
wat ik nog moet proberen op aanraden van gerolf is een 10 nF condensator over de uitgang van de opto zetten

graag ook wat info over jullie ervaring met opto couplers

gr raf


Titel: Re: opto couplers
Bericht door: Michiel op 13 augustus 2019, 14:37:12 pm
Ik gebruik een bijna identieke opzet:

- optocouplers IC 817
- diodeschakeling met 4 diodes (of gelijkrichterbrug met + en -  verbonden)
- 33 ohm voorschakelweerstand voor optocouplers.
- 10nF parallel over de diodeschakeling om trager te schakelen
- 4K7 ohm parallel over de diodeschakeling om het minder gevoelig te maken (ongeveer 3mA)

Ik heb over het algemeen geen probleem, behalve met sommige locdecoders die hoogohmig lijken te gaan wanneer de trein stil staat. In de locs zal ik dus meestal een 2K2 ohm weerstand toevoegen over de wielen om een permanente belasting te hebben.

Jouw verhaal met Railcom is interessant. Daar heb ik niet aan gedacht, en is misschien de oorzaak van die "hoogohmige" toestand van mijn decoders. Bij tijds ga ik dit eens proberen uit te zoeken. Bedankt voor de tip.  ;)
Titel: Re: opto couplers
Bericht door: raf op 13 augustus 2019, 15:34:11 pm
hoi Michiel

we hadden eerst deze opzet maar dat gaf ellende met de detectie op de opstel sporen
meestal als de loco weg is en de wagons staan nog op de opstel sporen dan om een of andere reden viel de bezet melding weg
nu ik de 4K7 en de 10 nF heb weg gelaten is dit probleem ook van de baan

we hadden verleden week een loco die wel detecteerde maar voor de rest door de abc uit reed
maar dat is een ander probleem

het knipperen van de led's is minder na dat we deze hebben weg gelaten maar er zit zo nog een klein pinkje in
ik maak morgen een filmpje

na het weg laten van de 4K7 en de 10nF was er wel een probleem op een stuk van de baan
we hebben eerst prototype modules gebruikt die op vero board gebouwd waren om te kunnen testen
er zijn ondertussen wel 6 versie van gemaakt
die hadden allemaal die 4k7 en 10 nF en werkten naar behoren
nu ik vervang een prototype (ze zien er echt niet uit ) door een productie module en opeens bezet melding zonder dat er iets op stond
maar het rare was dat er niet direct bezet melding was het duurde ongeveer 2 à 3 seconden
ik heb dan de 39 ohm vervangen door een 120 oHm weerstand en dan was dat probleem opgelost
de bezet melding werkt nu naar behoren dachten we
we zijn aan het bedenken geweest waarom juist daar op dat stuk .we hebben daar al meer ellende gehad voordien .dit is niet het langste blok van allemaal dus antenne via de sporen sluit ik uit .
na het vervangen van de nieuwe module door een tweede exemplaar werkte alles gewoon ook met de 39 oHm weerstand

rail com is pure ellende en zeer weinig over te vinden
onder de baan zitten drie boosters met een link module
op 2 hadden we railcom dat was die aan de ecos centrale zelf en dan booster 3
op boosters 2 nooit railcom maar daar was het geen hinder omdat het daar gewoon doorgaand spoor is
booster 3 daar is een rangeerstation en een electro depot en diesel depot vanwaar de loco's allemaal vertrekken
als de baan opgestart word

de railcom heeft na testen niets te maken met de bezet melders met of zonder weerstand combinatie
morgen ga ik testen met een verleng kabel of ik het electro depot aan het werk krijg met railcom
als dat werkt en de opstel sporen werken ook dan is er een probleem met de linkmodule

ik ben benieuwd naar je ervaringen met railcom  want echt weinig over te vinden
de weerstand en condensator plaatsen
(http://usuaris.tinet.cat/fmco/images/railcom_signal.gif)
zo werkt railcom eigenlijk
dan op een ander forum blijkt weer als er een tams decoder ergens op de baan staat deze de railcom zou storen
(https://forum.3rail.nl/index.php?action=dlattach;topic=63055.0;attach=119323;image)

deze zitten wel onder de club baan maar zoals gezegd op 2 boosters geen railcom
morgen testen

gr raf


Titel: Re: opto couplers
Bericht door: patrick smout op 13 augustus 2019, 23:19:23 pm
Dag Raf,

Dat de detectie beter werkt zonder 4k7 indien een loc niet aanwezig is zou veroorzaakt kunnen worden door een te grote contactweerstand tussen de wielen van rijtuigen en de rails bij  stilstand. Dit vormt dan een spanningsdeler met de 4k7 . Als de overgangsweerstand te groot wordt is er geen detectie meer. Zonder weerstand gaat alle stroom door de opto ( hoe klein ook).

Voor de keuze van de weerstanden is de CTR ( current transfer ratio) van de opto doorslaggevend. Een opto heeft een versterking (CTR) net zoals een transistor en ligt meestal tussen de 50% en 600%. De CTR is de verhouding van de collectorstroom gedeeld door de Ledstroom. Stel dat er een collectorweerstand is van 4k7 naar +5V. Als de transistor in verzadiging is geeft dit een stroom van 1mA. Bij een CTR van 50% heb je dan minimaal een ledstroom nodig van 2mA. Bij 4 diodes heb je ongeveer 1,4V min spanningsval led opto (1,2v) over de weerstand staan. Ledweerstand moet dus kleiner zijn dan 100Ohm in dit rekenvoorbeeld. Echte cijfers zie datasheets.
Om een detectieschakeling ongevoeliger te maken kan je ook de collectorweerstand verkleinen ( of weerstand parallel aan diodes). Wel oppassen dat deze niet te klein wordt omdat collectorstroom beneden de max moet blijven.

Het terminator circuit lijkt me van weinig tot geen invloed te hebben op de werking van de stroomdetectie. Het dient vooral om de signaalvorm van het DCC signaal wat op te poetsen. Als er al een verschil merkbaar is dan zou dit zich vooral laten opmerken door het feit dat er minder decoders  met kuren op de baan staan. Persoonlijk ben ik niet overtuigd van de toegevoegde waarde in deze toepassing.

Mvg,

Patrick Smout
Titel: Re: opto couplers
Bericht door: patrick smout op 13 augustus 2019, 23:32:43 pm
Ter aanvulling. Bij een opto is er nogal een ruime spreiding op de CTR. Bij deze toepassing dus rekenen met de minimale CTR uit de datasheet en dat komt het wel goed.
Bij andere toepassingen moet de CTR binnen bepaalde kleinere marges liggen. Bij aankoop van een opto specificeert men dan de BIN . De BIN specificeert welke CTR men wil ( gain range). Deze opto zijn duurder omdat ze werkelijk gesorteerd zijn volgens  CTR. Typische toepassing is bvb. In een terugkoppeling waar men zekerheid wil hebben over de gesloten lusversterking. ( te groot is oscilleren, te klein is geen of slechte werking).

Grtz,

Patrick
Titel: Re: opto couplers
Bericht door: Michiel op 14 augustus 2019, 07:29:14 am
Ernorm bedankt voor deze uitgebreidde uitleg, Patrick. Ik zal het nog een paar keer moeten herlezen, en eens zelf met wat rekenwerk aan de slag gaan om te begrijpen wat je precies vertelt, maar bijzonder interessant.

Zelf heb ik vroeger ook wat liggen spelen met terminator impedanties op de DCC lijn, maar gaf nooit een merkbare verbetering in de werking van de aangesloten toestellen. Heb het dus maar gelaten.
Titel: Re: opto couplers
Bericht door: patrick smout op 14 augustus 2019, 22:05:08 pm
Graag gedaan hoor Michiel  ;).
Over een opto is nog meer te vertellen.

De CTR van een opto is onderhevig aan degradatie. De mate waarin dit gebeurt is ondermeer afhankelijk van de ledstroom en de omgevingstemperatuur. In deze applicatie is de led meestal uit zodat dit niet echt speelt. In toepassingen waar de ledstroom meestal niet 0 is, moet je bij je berekening rekening houden met de veroudering ( aging) die optreed over een langere periode (10 - 15 jaar). Voor je berekening moet je dan de minimale/maximale waarde met bvb. factor 0,2 - 0,5 vermenigvuldigen ( datasheet geeft je de correcte getallen).

Voor ons hobbywerk is dit allemaal niet zo spannend. Voor professionele ontwerpen die in grote aantallen lopen en waar bvb componenten van verschillende fabrikanten door elkaar gebruikt worden kan behoorlijk wat spreiding zitten. Omwille van deze reden kan je zelfs op een heel eenvoudige schakeling best wel wat rekenwerk hebben.

Mvg Patrick
Titel: Re: opto couplers
Bericht door: raf op 15 augustus 2019, 12:35:14 pm
hoi patrick
de gebruikte opto is de pc817
gisteren op de baan een module ingebouwd en perfecte detectie
je vinger over de sporen leggen deed de detectie werken

maar na een 30 tal minuten opeens zonder bezet te zijn detectie dus ????
hier thuis op een 20 meter lang blok uren na elkaar geen detectie bij onbezet spoor
op een andere baan het zelfde geen detectie bij onbezet

en op de club baan wel
mijn test spoor ligt op een tafel in de garage zonder meer het is een test baan
bij patrick het zelfde gewoon op een plaat gespijkerd

maar op de club hebben ze de gehele baan met ballast in gebed
en nu blijken dit echte steentjes te zijn die met lijm zijn ingebed
nu vermoed ik dat deze steentje onderhevig zijn een vocht
en ook de blokken zijn wel bepaald maar die steentjes lopen van het ene blok naar het andere
en zo zouden die door de super gevoelige detectie wel eens de oorzaak kunnen zijn van de bezet meldingen

nu ga ik een module voorzien van een 10K potmeter over de diode's en dan door dit in te stellen de gevoeligheid van de detectie beïnvloeden tot ik op het punt kom van gevoelig maar niet in de detectie gaan
want men vind wel detecties met een 4K7 weerstand maar is die wel juist
ok ik zit aan bepaalde weerstand waardes vast maar ben toch benieuwd om te zien of er op de club baan enig verschil gaat zitten tussen de blokken onderling
en of ik een gemiddelde weerstand waarde kan vinden die voor alle blokken werkt

gr raf en ik ga uwen uitleg nog eens lezen




Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 15 augustus 2019, 12:41:05 pm
je vinger over de sporen leggen deed de detectie werken

maar na een 30 tal minuten opeens zonder bezet te zijn detectie dus ????
Dan is de detector veel te gevoelig. Zet een 4k7 parallel over de diodeschakeling en je zit goed. Niet nodig om te experimenteren met een potmeter, dat hebben anderen al voor je gedaan.
Titel: Re: opto couplers
Bericht door: raf op 15 augustus 2019, 12:52:37 pm
hoi Klaas
dat is het probleem die 4K7
op het ene blok heb ik detectie en op het andere niet
dus die 4K7 klopt niet voor alle blokken

https://www.youtube.com/watch?v=GP38HA5HI34&feature=youtu.be (https://www.youtube.com/watch?v=GP38HA5HI34&feature=youtu.be)

hier gaat het over de blauwe ledjes die flikkeren
dit is de bezet melding van de opstel sporen
dit zijn alleen wagons want de loco's zijn naar het depot verhuisd
maar met of zonder loco de leds flikkeren altijd
4 X 1N4007 diodes
1 X 4K7 met 10nF condensator
opto met 39 Ohm weerstand
aan de andere kant van de opto
10K naar de + 5 volt
led met weerstand 1 K naar de 5 volt

en hier thuis op de roco muis en bij patrick thuis geen geflikker
bij de opstel sporen is er geen ballast die roet in het eten komt gooien
de rode led's geven het gekozen opstel spoor aan die hebben dus niets met de detectie te maken

gr raf
Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 15 augustus 2019, 13:14:54 pm
Vreemd verschijnsel. De wagens op de opstelsporen, nemen die stroom af zodat ze gedetecteerd worden? M.a.w. horen die ledjes aan of uit te zijn?

Ik gebruik zelf andere detectors, met een enkel paar diodes en daar 1k overheen. Nog nooit problemen gehad met falende detectie of onterechte detectie.
Titel: Re: opto couplers
Bericht door: raf op 15 augustus 2019, 13:22:18 pm
hoi Klaas
die wagons zijn voorzien van of sluitlichten of weerstand lak of verlichting .sommige hebben ook een decoder er in zitten .
bij bezet melding horen de leds aan te zijn

rij jij ook digitaal ??? want analoog is er geen probleem
met een roco muis is er ook geen enkel probleem wat detectie aan gaat
de detecties zijn dezelfde als op de andere modules maar dan zonder processor er achter
gr raf
Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 15 augustus 2019, 14:25:55 pm
Ik rij niet digitaal maar Permaloog (https://people.zeelandnet.nl/zondervan/permaloog1.html) Dat is analoog, maar wel met een 20kHz blokspanning op de baan voor permanente verlichting. De spanningsvorm lijkt op digitale spanning dus elektrisch gezien wel vergelijkbaar.

Wat mij in het filmpje opvalt is dat niet alle blauwe leds knipperen. Is er misschien een verschil tussen de opstelsporen? Je zou eens wat spooraansluitingen om kunnen wisselen om te zien of het aan de detector ligt of aan het spoor zelf
Titel: Re: opto couplers
Bericht door: raf op 15 augustus 2019, 14:33:28 pm
klaas dat liegt aan de camera
want de leds flikkeren allemaal tegelijk
ik heb deze reeds verwisseld en andere detecties gemaakt alles blijft

permaloog is niet echt digitaal omdat er maar alleen een positieve puls is
digitaal is ook een negatieve pull dus zeg maar wissel spanning
alee volgens mijn scoop toch

de decoders in de loco's reageren door te remmen als je het signaal asymmetrische maakt
dit gebeurt niet bij permaloog

ook de dode pauze in het dcc signaal om de terug melding kan dit veroorzaken omdat dit de railcom gelegen heid geeft om gegevens van de loco's terug te zenden naar de centrale

dit is niet van toepassing op mijn roco muis
want die heeft geen rail com

gr raf
Titel: Re: opto couplers
Bericht door: patrick smout op 15 augustus 2019, 14:44:39 pm
Dag Raf,

Zoals ik het zie zit je met minstens 2 zaken die de boel wat verzieken. Als dezelfde detector in 2 verschillende blokken anders reageert zit je met een externe invloed. Een 2e gegeven is dat mogelijk de assen die voorzien zijn van weerstandslak onderling verschillend kunnen zijn in weerstandswaarde. Weet jij wat de minimale weerstandswaarde is van een as? Ben jij zeker dat de detectie altijd werkt met 1 as? Je kan ook een test doen door alle rijtuigen te verwijderen en te vervangen door een potmeter. Op deze manier kan je ook de gevoeligheid bepalen in een gcontroleerde manier. Wat gebeurt er als je de potmeter dan in een ander blok zet? Wel of geen detectie? Flikkering?

Heb jij een scope?


Mvg, Patrick
Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 15 augustus 2019, 14:52:27 pm
permaloog is niet echt digitaal omdat er maar alleen een positieve puls is
In Permaloog zitten ook negatieve pulsen. Dus als een trein niet rijdt, dan is er alleen maar een blokvormige wisselspanning van 20kHz.

Op een ander forum heb ik gelezen dat dit probleem kan ontstaan door RailCom. Staat dat op de centrale aan? Zet het dan eens uit.
Als RailCom aan staat wordt het digitale signaal steeds kort onderbroken (heel even geen spanning op de baan) zodat de decoders gelegenheid krijgen om terug te praten. In die korte pauzes heb je dus ook geen detectie.
Titel: Re: opto couplers
Bericht door: raf op 15 augustus 2019, 15:03:00 pm
ja klas railcom staat dus aan en dat is volgens mij ook de reden van dat flikkeren
gerolf heeft reeds een tekening doorgestuurd om een condensator te plaatsen aan de opto uitgang
dit ga ik doen bij de volgende reeks detecties van het bovenste schaduw station
indien dit effectief is dan zet ik deze ook op het onderste

gr raf
Titel: Re: opto couplers
Bericht door: Frank_N op 15 augustus 2019, 16:02:07 pm
Waar ik (bij analoog bedrijf) nog verbetering kon bereiken was een 2e optcoupler (CNY17) antiparallel schakelen over de eerste.
Of een bidirectionele optocoupler (ILQ620)  gebruiken (zelf niet getest). De condensator truuk achter de opto had ik ook gevonden, maar zie net dat Gerolf me voor was. Het resultaat is een aanmerkelijk stabieler signaal.
Titel: Re: opto couplers
Bericht door: raf op 15 augustus 2019, 17:08:29 pm
mea coulpa ik heb me vergist
het is niet de pc 817 die ik heb gebruikt maar de pc814 en dit is een ac opto laat het ons zo maar zeggen
deze heeft twee diode's in plaats van 1

daar de opto's in voetjes zitten zou ik ze gemakkelijk kunnen wisselen maar ik dacht al ???? een enkele had ik toch niet liggen en dus vergist in nummer

maar we kunnen dus aan nemen dat de condensator achter de opto een beter resultaat geeft

dan ga ik dus seffens 2 printen uitrusten met een extra condensator ( 10 nF)en woensdag testen of het een verbetering is

spijtig dat ik hier thuis het probleem niet kan simuleren want dan kon ik het hier testen


gr raf en bedankt voor het mee denken
Titel: Re: opto couplers
Bericht door: Frank_N op 15 augustus 2019, 18:24:17 pm
 ??? Ik kwam op 4u7 met een transistor als buffer erachter, heb het project verder (nog)niet afgewerkt.
Maar het kan natuurlijk best zo zijn dat de door Gerolf voorgestelde waarde van 10nF in uw situatie soelaas biedt.
Titel: Re: opto couplers
Bericht door: raf op 15 augustus 2019, 20:18:49 pm
ik denk dat de transistor voor het sturen van de led niet veel toevoegt
een bc 547 zou kunnen maar een led trekt geen 500 Map

pd pc814 heeft een CRT van 20 tot 300
en kan 50mAp leveren

dus meer dan voldoende voor een led dacht ik

gr raf
Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 15 augustus 2019, 21:58:03 pm
Raf, je moet oppassen dat je jezelf niet rijk rekent.
De maximale CRT is 300%. Stel dat je led aan 3mA genoeg heeft, dan moet er door de leds in de opto minstens 1mA lopen. Maar die optoleds staan in serie met een weerstand en daardoor zal het grootste deel van de detectiestroom door de diodebrug lopen. Je zal dus zo uit de duim berekend een totale detectiestroom van 10mA nodig hebben. Je zit dan naar mijn idee wel op de grens te werken.
Ik zou toch achter die opto nog een transistor zetten met een vertragingsnetwerkje. Dan krijg je een beter reproduceerbaar resultaat en ben je ook van dat geknipper af.
Titel: Re: opto couplers
Bericht door: raf op 16 augustus 2019, 11:03:33 am
hahaha klaas daarom noemen ze dat lopen op de schreef

ik weet het en ik ga woensdag kijken of de condensator enige oplossing heeft geboden
dat ze een beetje flikkeren kan trouwens geen kwaad
maar zoals ze nu doen word het een kermis

dus afwachten tot donderdag voor het vervolg
wat ik nog altijd kan doen is de weerstand in serie met de opto verlagen om zo iets meer mA door die led te kunnen sturen

gr raf

Titel: Re: opto couplers
Bericht door: raf op 22 augustus 2019, 10:50:52 am
ok verslag van gisteren

de module uitgebouwd en er een met een 4K7 weerstand ingezet en ?????

de wagon met sluitlicht werd niet gedetecteerd (dit is de test wagon voor alle blokken)
ok dan een loco op het spoor en wel detectie maar zo van wel en niet
dus geen bruikbare detectie voor een constant bedrijf

de module op een ander blok gehangen en daar werkte ze wel dus module in orde

nu dit is een zeer lang blok en ik ben er over aan het denken om dit op te splitsen in twee blokken
dan kan ik mits software aanpassen dezelfde module gebruiken
deze doet dan detectie van het halve blok en linkt dan het voorliggende door naar het achterliggende zodat eigenlijk toch heel het blok gedetecteerd word
dan hoef  ik geen nieuwe print te maken

maar blijft dat toch raar vinden en ik ga een laatste verzoek doen door een module een regelbare weerstand te zetten om te kijken welke waarde van weerstand ik ga uit komen om toch een goeie detectie te hebben

ombouwen is 2 draden voeding los maken ,een stekker 12 volt en dan de opto het voor en achterliggende blok en de 2 stekkers voor de signalen
dus snel gedaan als je het gewoon bent

morgen proberen of het lukt met die regelbare weerstand in plaats van die 4K7

gr raf
Titel: Re: opto couplers
Bericht door: raf op 24 augustus 2019, 10:50:55 am
gisteren het lange blok van 8 meter opgedeeld in 2 blokken van 4 meter
het nieuwe blok werkt met een standaard module perfect en het ouder resterende blok blijft shit

het rare is dat de bezet melding onregelmatig is
soms 5 minuten soms 20 minuten en dan weer opeens binnen 1 seconde

door andere werkzaam heden op de baan geen tijd gehad om de regelbare module in te bouwen
dat zal dus voor woensdag zijn

voor de rest werkte alle zoals gedacht

gr raf
Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 24 augustus 2019, 11:06:15 am
Raf, dat slecht werkende blok, is dat elektrisch wel goed gescheiden? En zit er geen sluipverbruik op, b.v. via vochtige ballast?
Kwestie van een ohmmeter er tegen houden, moet oneindig meten.
Titel: Re: opto couplers
Bericht door: raf op 24 augustus 2019, 11:29:34 am
hoi Klaas

dat is volgens mij het probleem
het blok is gescheiden dat had ik reeds gemeten
doe ik trouwens altijd voor ik de module aansluit

de bedding bestaat uit natuursteentjes met lijm vast gelegd
nu dit blok heeft maar een bedding van 3 meter de rest is in de berg en niet in gebed

woensdag eens meten  of er weerstand is maar dan blijft het probleem alsnog bestaan
het blok loopt over 2 bakken (module baan)en dus aan de koppen is er zeker geen invloed van de ballast die verder door geeft
een bak is 2.24 lang dacht ik

het blijft gek gedoe met die detectie
standaard is er geen 4k7 weerstand en de meeste  blokken werken daarop perfect
dan is er een zeer lang blok met ellende maar dit is opgelost door een 4K7 en een andere weerstand naar de opto  (39 ohm in plaats van 120)

dan dit nieuwe probleem blok van 4.50 ongeveer wat er nu over is waar een 4K7 helemaal geen detectie geeft
een wagon met sluitlicht geeft dan geen detectie en een loco zeer moeilijk
zonder weerstand perfecte detectie maar dan om de zoveel tijd bezetmelding
en dan valt natuurlijk de baan stil om dat achterliggend signaal op rood komt

daarom wilde ik een regelbare module in bouwen zodat ik de juiste weerstand kon bepalen zonder in te boeten op gevoeligheid

maar woensdag meer

gr raf



Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 24 augustus 2019, 12:51:18 pm
Raf, ik vrees dat een regelbare weerstand niet gaat helpen. Als je de ene keer moeilijk detectie krijgt terwijl die er wel moet zijn, en de andere keer wel detectie terwijl die er niet moet zijn, dan zijn dat tegengestelde gebeurtenissen. Dan zou ik het toch zoeken in een slecht contact of een sluimerende sluiting.

Als dat blok over twee bakken doorloopt kun je ze loskoppelen en afzonderlijk meten. En dan ook eens kritisch kijken naar hoe die doorverbinding er uit ziet.
Titel: Re: opto couplers
Bericht door: raf op 24 augustus 2019, 14:23:53 pm
hoi klaas
het volledige blok is opnieuw bekabeld geworden van de solderingen ben ik zeker

je moet eerst de opzet van het systeem begrijpen wat we en hoe we het doen daarvoor een pm

wat de module aan gaat ik heb er meerdere zonder weerstand aan gehangen alsook met weerstand het probleem blijft bestaan

dus de module kan ik uitsluiten want ergens anders op de baan werken ze wel

ik wil nu met die regelbare weerstand een waarde zoeken waar ik detectie heb met de test wagon en toch geen onbedoelde bezet meldingen

zeg maar op zijn belgische een compromis vinden

dan kan ik deze als vaste weerstand op een module zetten en deze in de plaats van die test module zetten
en dan kijken of het is opgelost
nu verder werken doe ik niet voor dit is opgelost want anders blijf ik het probleem voor me uit schuiven



Titel: Re: opto couplers
Bericht door: Havoc op 25 augustus 2019, 10:03:48 am
Raf, wat Klaas bedoelt is dat je het onderliggende probleem waarom dat ene blok niet werkt zoals de andere moet oplossen. Je kan trachten die ene speciale weerstandswaarde te vinden waarmee het vandaag werkt, maar morgen als het wat vochtiger, droger, warmer, kouder of misschien bij volle maan, dan zal het plots terug niet werken.

Als je module met alle andere blokken wel werkt, maar met dat ene blok niet, dan is het blok het probleem, niet de module. Hang er je standaard module aan en werk aan het blok totdat de module detecteert zoals het hoort.
Titel: Re: opto couplers
Bericht door: raf op 25 augustus 2019, 10:59:18 am
hallo Johan

dat is het probleem ;het is een reeds bestaande baan en zomaar eventjes iets afbreken en opnieuw leggen gaat me helemaal niet in dank afgenomen worden
door de andere leden

ik ga woensdag nog wat testen met de regelbare module
deze aansluiten is niet veel werk
 twee draden detectie ,display aansluiten en stroom en meer moet ik niet aansluiten
de rest is maar voor de voorgaande en achterliggende blokken
ik moet alleen de detectie testen niet al de rest wat de module ook nog kan
als ik dan met de regelbare test weerstand een waarde heb verkregen dan kan ik kijken hoeveel ze afwijkt van die 4K7
hoe hoger de weerstand hoe gevoeliger dat blok reageert
met geen weerstand dus super gevoelig

als ik dan de gevoeligheid zo krijg dat BV de loco altijd gedetecteerd word dan heb ik een waarde
daarna afregelen met de test wagon dan heb ik waarde twee
en die mogen niet ver uit elkaar liggen en dan kan ik een compromis vinden tussen de twee
ik zit met een deadline namelijk de eerste vrijdag van de maand is het telkens rijdag en dan moet de baan werken .dat de blokken niet allemaal werken is geen probleem de leden moeten kunnen rijden
begrijpelijk dat wel
er staan dan op de baan "stop"borden zodat ze weten dat vanaf daar geen detectie meer is en het manueel rijden betreft tot "einde stop bord"
ik denk dat er 4  aansluit draden naar het probleem blok gaan en daar ga ik volgende keer eens naar kijken
dan deze los maken en een voor een aansluiten tot ik met de standaard module weer het probleem heb
dan weet ik toch al op welk deel van het blok het probleem zich voordoet en kan ik me op dat deel concentreren om daar een oplossing voor te vinden .

nooit plezant om op een ban die eerst analoog was en daarna voorzien was van pakweg 600 relais voor een station alleen  en dan half digitaal en daarna koploper ook zonder succes en dan weer iemand anders tot uiteindelijk eric ,patrick ,ik en phillipe er aan begonnen zijn.
we zijn  onder tussen reeds veel tegen gekomen wat ook problemen veroorzaakt ongeacht welk systeem er gebruikt word
en ok litfinski en andere merken zijn voor thuis banen ok maar voor zo een grote baan werkt het niet door de zeer lange draden die nodig zijn tussen de modules onderling en de blokken op de baan
en dan heb je nog de loco's zelf die voor problemen zorgen qua instellingen

hier thuis op de test baan werkt alles perfect hoor met en zonder weerstand
en hier is een blok 16 meter als het moet zijn met wissels en dergelijke er in
maar ik rij met roco muis
bij pascal met ecos ook geen problemen en werkt alles zoals gedacht maar zonder railcom
en op die baan word er railcom gebruikt 

nu wachten tot woensdag en dan weet ik meer
gr raf 




Titel: Re: opto couplers
Bericht door: Havoc op 25 augustus 2019, 11:01:46 am
Op de tijd dat je er al mee bezig bent was het al afgebroken en herlegd geweest. Soms is de korte pijn de beste.
Titel: Re: opto couplers
Bericht door: raf op 25 augustus 2019, 11:20:51 am
niet mijn eigen baan johan maar club baan

anders was de elektronica meteen mee gedaan met het leggen van de baan
nu is het eenmaal zo en roeien met de riemen die ik heb
en zomaar afbreken gaat niet er staat reeds boven leiding en heel het landschap er omheen is ook reeds klaar

en geduld is een mooie deugd
er kan gereden worden en dat telt
eens dit probleem is opgelost zal er wel een ander opduiken hahaha
ik denk dat er zeker nog een 100 tal zaag sneden in de rails zitten die hersteld moeten worden
eens kijken of ik in dit blok geen zaag snede gemist heb want dat kan ook voor ellende zorgen

gr raf
Titel: Re: opto couplers
Bericht door: Dirk op 25 augustus 2019, 12:48:02 pm
Op de tijd dat je er al mee bezig bent was het al afgebroken en herlegd geweest. Soms is de korte pijn de beste.

Dan zou ik je voorstellen om eerst eens naar de baan te komen kijken, 500m+ sporen en een omlooptijd van 20 minuten.... daar haal je zomaar geen stuk tussen uit. Laat Raf zijn ding maar doen, respect wat die allemaal bedacht heeft voor de club. De baan bestaat uiteindelijk uit meerdere delen die samen gevoegd zijn tot 1 geheel, de leden willen manueel rijden, maar toch moet er beveiliging zijn. Ik heb ooit proberen uit te vogelen om het met Koploper te doen, maar daar ben ik mee gestopt. Manueel rijden met 2,3,4... personen en dan toch beveiligd zijn. Nogmaals respect.

Dirk
Titel: Re: opto couplers
Bericht door: raf op 25 augustus 2019, 13:20:20 pm
hoi Dirk bedankt voor de toelichting
hier een stukje van de baan .dit is echt een KLEIN stukje nog niet 1/5 van het geheel

https://www.facebook.com/knock.broekvent/videos/2539487539436713/
dit stuk is nu buiten het depot reeds helemaal voorzien van beveiliging
ook de andere kant van de zaal werkt zoals het moet
ik denk dat we nu aan een stuk of 30 blokken zitten
er zijn speciale blokken bij die BV de slagbomen mee bedienen en als de trein voorbij is dan gaan ze ook weer omhoog ongeacht de lengte van het trein stel

er zit een pak programmatie in en daar zit niet het probleem
de hardware en dan meer de baan zelf speelt me parten

maar de boer ploegde verder en had te vreten op het laatste van de rit

gr raf
ps de opname was gedaan door een buur jongen die op bierbakken en trapjes moest gaan staan om de baan te kunnen overzien ;en door de grote van de hal ja moeten we al eens roepen
Titel: Re: opto couplers
Bericht door: raf op 29 augustus 2019, 09:31:57 am
zo gisteren dan het probleem blok aangepakt

zoals gezegd had ik een regelbare module mee om te kijken van hoe en wat
ik test altijd met een wagon met sluitlicht en als deze goed detecteert dan is het voor de rest van het wagon park ook ok

dus ik zet deze reeds op de rails en begin de module los te maken en ????
shit het sluiticht blijft branden dus er komt ergens anders stroom vandaan
daar dit een bestaande baan is en deze vroeger analoog was en eigenlijk uit drie banen bestaat is fout zoeken niet zo makkelijk
dus het naast liggen de blok de voeding ook los gehaald en het licht ging uit
dus er was een verbinding tussen de twee blokken
sectie per sectie los gemaakt en ja hoor een bleef stroom krijgen
zat me daar toch een verbinding IN het gebruikt pur schuim zekers
zo goed als niet te zien maar nu ik er naar opzoek was dus wel gevonden
verbinding doorgedaan en kijk het  blok werkt

het eigenlijke probleem was dat door die verbinding er een blok van 16 meter was ontstaan en dit dus inderdaad een probleem gaf met de detectie
waarom er een bepaalde tijd over ging voor het blok bezet werd zal wel ergens een oorzaak hebben van capacitief  stroom op bouwen denk ik

maar probleem opgelost volgende probleem aan pakken LOL
maar dat is gelukkig software en dus lekker thuis zitten en programmeren
gr raf
Titel: Re: opto couplers
Bericht door: Klaas Zondervan op 31 augustus 2019, 22:54:31 pm
Raf, in reactie #25 had ik je al gevraagd of het blok wel goed van de buren is gescheiden. Je zei toen dat je dat had gemeten maar er bleek dus toch ergens een valse verbinding te zijn.
Maar goed het is nu opgelost en in de toekomst hoef je bij dergelijke problemen niet met regelbare weerstanden aan de slag want bij de beschreven verschijnselen kan het daar niet aan liggen.
Titel: Re: opto couplers
Bericht door: raf op 31 augustus 2019, 23:53:09 pm
hoi klaas
inderdaad ik had dat gemeten maar om de een of andere onverklaarbare reden  gaf de meter geen spanning
dus dan dacht ik ok dit blok is gescheiden van de rest
maar vandaag met dezelfde meter wilde ik op 20 amp aan het water een motor verbruik meten en ??? niks
de motor wilde zelfs niet draaien 
trok ik aan de meet pen en de kabel kwam daar gewoonweg uit
dus die zal van toen reeds over geweest zijn en zo had ik dus kunnen meten tot ik een ons weeg

dus nu ga ik me zelf aan leren dat ik eerst de kabels eventjes door piep met die stand op de meter
dan zou dat niet meer mogen voor komen
 
maar het is opgelost en nu gaat die potmeter van die print (twee draadjes) en kan ze voor de rest gewoon in het blok systeem verder worden ingebouwd

gr raf
Titel: Re: opto couplers
Bericht door: raf op 02 maart 2020, 19:40:49 pm
the never ending story dan maar

ok de blokken werken en er is perfecte detectie zelf de abc werkt zoals het moet
signalen en voor seinen alles werkt zoals het moet
en toch is er nog ellende
nu toen patrick (zaliger) en ik er aan begonnen hebben we om een of andere reden diode's gebruikt die voldoende aanwezig waren op de club
dit als inleiding
als we woensdag's aan het werken zijn dan rijden er een lok of 5 à 6 op de baan rond waarvan sommige met een poets wagon er achter
dan hebben we zo goed als geen problemen op een 10 uur rijden dus we dachten ok het systeem is in orde en we bouwen verder

nu op de rij avonden kunnen we ongeveer een 2 uur goed rijden en dan begint de ellende de treinen gaan in abc ook daar waar ze niet moeten stoppen
een test loc met een V3 decoder draait zonder problemen zijn rondjes want die heeft geen abc

nu ben ik de gegevens van de diode's gaan na kijken en die kunnen maar max 1 amp aan
en ik denk dat daar de fout zit dat na 2 uur rijden met treinen van 5 à 6 meter deze diode's warm worden en dan van waarde vergaan
nu hebben we een test gedaan met 3 omgebouwde modules met BY251 type diode's en daar bleef alles voorlopig goed werken
nu heb ik bijna een 15 modules omgebouwd en nu woensdag eens kijken als die er allemaal onder zitten hoe op dat stuk baan de 6 meter lange treinen zich gedragen en dat het rem probleem is opgelost

blijft nog het probleem van de railcom die niet wil werken
door de ombouw van de gehele baan zijn we nu bundels kabels er onder uit aan het halen die niet meer nodig zijn
stekkers en door verbinders en nog bekabeling van 20 jaar geleden komt er allemaal onder uit
nu kan het zijn dat de weerstand met condensator filters niet mee aan de ring leidingen zitten en we deze terug moeten gaan plaatsen
maar eerst kijken of de baan nu volgende week vrijdag goed blijft rijden en dat dit probleem is opgelost

dan naar de railcom gaan kijken en dat probleem oplossen

gr raf en alle info over die railcom is welkom