Auteur Topic: Servo controller DR4024 met relais uitgang => probleem  (gelezen 203 keer)

Offline Cedric

  • Forumlid
  • Berichten: 183
    • foto's via flickr
  • Voornaam: Cedric
Servo controller DR4024 met relais uitgang => probleem
« Gepost op: 15 april 2018, 16:39:32 pm »
Goeiemiddag, recent iets raars voorgehad met mijn Digirail DR4024 dcc servo controller.

Ik gebruik voornamelijk Sand4Servo decoders van Sven Brandt (zie site digital bahn) om met servo's mijn wissels te sturen, maar één wisselsturing met servo heb ik als test verbonden met een DR4024 van Digikeijs.

De digikeijs decoder zelf is voorzien van een servo-uitgang en een schakelaansluiting die meeschakelt voor de wissel te polariseren. Ongeveer een jaar geleden heb ik deze getest en aangesloten, alles zonder problemen. Om de wissel te polariseren heb ik zelf een printje met relais gemaakt die aangesloten is op de schakeluitgang (cf het schema van hun product DR4102 https://www.digikeijs.nl/dr4102-puntstuk-interface.html). Die werd ook netjes van vrijloopdiode voorzien. De relais die gebruikt werd is een G5V-2 van 12V DC (bij digikeijs werkt men met een enkelpolige G5V-1, ik gebruik een dubbelpolige want deze had ik nog liggen)

Zie ook helemaal onderaan de handleiding van de DR4024:
https://www.digikeijs.nl/dr4024-4-kanaals-servodecoder-met-4-extra-schakeluitgangen.html

Sinds enige tijd merkte ik dat het puntstuk ook niet meer geschakeld werd. De schakeluitgang voor het relais daarentegen stond altijd hoog (ong 17V).
 Ik heb de decoder eruit gehaald en aan mijn test centrale gehangen (DR5000 naast mijn PC) en geprobeerd om deze uit te lezen omdat ik eerst dacht dat de cv instellingen door een of andere reden gewijzigd waren. Echter kon ik de cv's van de decoder noch lezen noch schrijven.

Gisteren heb ik een nieuwe DR4024 voorzien (volgende week moet de baan af vr mobexpo, lichte tijdsdruk dus  ;) ) en deze ook geprogrammeerd en ingesteld aan mijn test centrale, alles ok. Na inbouw hoor ik de relais klikken, maar nog altijd geen veranderende puntstukpolarisatie.
Dus werd het printje met relais eruitgehaald en getest met aparte voeding. Wat blijkt => de relais klikt bij schakelen, maar de uitgang verandert niet. Het puntstuk kan dus niet geschakeld worden

Nu, mijn concrete vraag. Zou mijn decoder stuk gegaan zijn en hierdoor ook het relais ? Of eerst het relais en dan de decoder ?
De spanning die uit de decoder komt voor het schakelen van de relais op mijn baan is 17V DC.
Als ik test met de Digikeijs DR5000 DCC centrale is dit ong 18,6V DC. Dus de spanning voor het relais te sturen is een pak hoger dan de 12V DC, maar als digikeijs dit zelf schakelt met zo'n hoge spanning vermoed ik dat het geen probleem is. Ik dacht indertijd dit ook eens gevonden te hebben in de specs (dat je dus een 12V DC relais met een hogere spanning mag sturen)

Iemand die dit kan bevestigen of hier praktijkervaring mee heeft ? Ik zou graag zeker zijn dat ik het relais of de decoder niet opnieuw kapot doe

Bovenstaande is een hele boterham en heb ik geprobeerd zo nauwkeurig mogelijk te beschrijven. Indien nog vragen stel ze gerust...

Alvast bedankt om te helpen meedenken  ;) :P

Offline INFO

  • Forumlid
  • Berichten: 2.635
    • http://www.rosoft.info
  • Voornaam: Wim
Re: Servo controller DR4024 met relais uitgang => probleem
« Reactie #1 Gepost op: 26 april 2018, 20:05:55 pm »
Als je hetzelfde relais gebrikt met en bij de andere decoder, dan ligt het niet aan de decoder maar aan het relais, als ik je verslag lees denk ik dat de contacten van het relais blijven kleven.

Groetjes
Alleen de waarheid ligt in het midden.